Jump to content
Sign in to follow this  
Abomally

Please fix the warlock Dreadsteed Dire Maul quest

Recommended Posts

As the title suggests, the warlock quest "Dreadsteed of Xoroth" seems to be incomplete. The problems I encountered are the following and my explanation of how I actually managed to complete it at the bottom*:

1. The glowing pylons in Dire Maul West (five in total) do not extinguish upon defeating the mobs surrounding them. This is necessary to drop the shield leading to Immol'thar's area in order to start the ritual.

2. Since the glowing pylons don't go out, the (blue) shield surrounding the area where the ritual is to take place is inaccessible.

3. When the ritual starts by releasing the Imp from J'eevee's Jar; the Bell (Bell of Deathmoora), the Wheel (Wheel of The Black March) and the candle (Doomsday Candle) do not get placed around the circle by the Imp as they should.

4. Since the items listed above do not appear, the warlock doesn't have to repair them. The group can simply kill the waves of mobs until the ritual completes.

5. The next part requires the warlock to click the Xoranthian Glyphs in order to summon and kill the Dreadsteed. This worked correctly; except that Lord Hel'nurath did not spawn near the end of the fight with the Dreadsteed as he should.

 

* Here's how things happened for me:

 

We entered Dire Maul West and proceeded to kill all of the elementals around the 5 pylons. None of them went dark, which we thought was strange. We reset the instance (after the first one) and tried again. The first pylon is near the entrance, so it was quick and easy to retry. Although the first one stayed lit up, we decided to continue. The next 2 pylons are upstairs. The last 2 pylons are down in the bottom of the instance, which is normally blocked by a door.

This door was missing. Lord Hel'nurath was down there as well as the Dreadsteed spirit and corpse. We figured that the developers set it up this way so that the quest could be completed without needing access to Immol'thar's area - which was still blocked by the blue shield. The bad thing is, although the Dreadsteed spirit has a grey question mark above it's head - it never turns yellow and the quest would not complete for me.  Yes, we killed Lord Hel'nurath and the other mobs as well, so I submitted a ticket in game.

Somehow, one of the people in our group was able to walk into Immol'thar's area. We managed to do this also, by walking straight in starting at a hallway behind us. Once inside, we killed Immol'thar and I began the ritual which proceeded as I listed above. Once the Dreadsteed was dead, I was able to talk to his spirit, complete the quest and obtain my Dreadsteed mount. I removed the in-game ticket since I was able to complete the quest, with the intention of posting here.

 

Maybe this will help some of you that are stuck and unable to complete the quest. I apologize if this has been addressed by the developers before (a forum search here produced no results).  Please fix this, as I would enjoy helping other warlocks obtain their Dreadsteed with what I consider to be a fun final event in this quest chain.

 

Edited by Abomally

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×